JobStaq - SMS Sender Ignored – Incident details

SMS Sender Ignored

Resolved
Degraded performance
Started 4 days agoLasted about 24 hours

Affected

Other

Degraded performance from 6:18 PM to 5:56 PM

SMS Sending

Degraded performance from 6:18 PM to 5:56 PM

Updates
  • Resolved
    Resolved

    An update is currently being released which fixes sender IDs for users who are using their mobile number as the sender.

    We apologies for any issues this issue has caused. As a result of this incident, JobStaq is now much more fault tolerant to SMS provider issues, and we've got several options to quickly switch to if any issues are identified going forwards.

  • Update
    Update

    An update is currently rolling out to transition messages sent from alpha-numeric sender IDs to a new provider, which should be complete in the next few minutes.

    Messages configured to be delivered with a mobile number a sender will continue to be sent from a pool of random numbers until a replacement provider has been identified.

  • Identified
    Identified

    We've identified an alternative messaging provider to support alphanumeric sender IDs, and will begin working to transition SMSs from these senders over to their platform. We're still figuring out the best path forwards for users who have the SMS sender as their mobile number.

  • Investigating
    Investigating

    Our SMS provider has made changes to their sending interface without any notification to us, which has resulted in all messages being sent from a shared pool of random UK mobile numbers, rather than the configured sender name or mobile number.

    It appears this issue started on April 1st, 2025. We're investigating the best steps forwards from here to get SMS messages back to being sent from the intended senders.