Database upgrades

Completed
Scheduled for February 18, 2024 at 12:00 PM – 4:22 PM

Affects

Web interace
API
Updates
  • Completed
    February 18, 2024 at 4:22 PM
    Completed
    February 18, 2024 at 4:22 PM

    Everything is operating again, and the maintenance window has finished. Thanks for your patience, we'll continue to monitor things to make sure everything continues working as intended.

  • In progress
    February 18, 2024 at 3:27 PM
    In progress
    February 18, 2024 at 3:27 PM

    We've put the API and server into maintenance mode while we work on creating backups and migrating data over to the new database.

  • Planned
    February 18, 2024 at 12:00 PM
    Planned
    February 18, 2024 at 12:00 PM

    We're making changes to our database infrastructure to increase resilience, in response to the brief outage experienced earlier this week. As a result, our API and web interface will be offline for a short period of time during this upgrade. The mobile apps will continue to work, though syncing will be unavailable until this upgrade has completed.