JobStaq - Background processing issues – Incident details

Background processing issues

Resolved
Degraded performance
Started 14 days agoLasted about 16 hours

Affected

Web interace

Degraded performance from 7:00 AM to 11:11 PM

API

Degraded performance from 7:00 AM to 11:11 PM

Other

Degraded performance from 7:00 AM to 11:11 PM

Email Sending

Degraded performance from 7:00 AM to 11:11 PM

SMS Sending

Degraded performance from 7:00 AM to 11:11 PM

Letter Sending

Degraded performance from 7:00 AM to 11:11 PM

Updates
  • Resolved
    Resolved

    All background jobs have been processed. We are working on improving monitoring & alerting around background jobs to ensure this does not happen again.

  • Monitoring
    Monitoring

    The backlog of queued background messages is currently recovering, and should catch up shortly.

  • Investigating
    Investigating

    Background jobs are failing to execute in a timely manner.